sudo: sorry, you must have a tty to run sudo

sudo: sorry, you must have a tty to run sudo

We're using an old version of Upstart, on Centos, to manage stopping and starting our Node.js daemons, and one of the things the...

Latest release information is not available for plugin ‘nimble’, specify concrete release to install

Whilst trying to install the Nimble plugin for Grails using Maven I ran in to a spot of bother! Chill:superted idimmu$ mvn grails:install-plugin -DpluginName=nimble Scanning...

Integrating Grails and Maven

I've started investigating Grails for some projects and have been making some good headway and I like to use Maven for everything as it's...

Building Your First VR Experience In Decentraland

This is a brief video and tutorial on building your first VR experience in the Decentraland VR platform and getting you started with the...

PHP Java Bridge in Ubuntu Gutsy with Lucene

The php/java bridge it a pretty awesome little protocol that basically lets us use java classes inside our own PHP applications! This lets you...
how to take control of another computer

How To Take Control Of Another Computer

There are several things to think about when taking control of another computer, the Operating System running on it, the speed of...

Unique Article Wizard needs strip slashes!

I'm playing about with the Unique Article Wizard plugin for Wordpress (for a friend, not for this site!!!) and there's an obvious problem where...

Elgg 1.8 Tidypics Group Fix

I'm creating a new community site using the Elgg 1.8 platform, but a lot of the widgets are still using the old 1.7 CSS...

How To Create An NPM Repository Mirror

We use Node.js a LOT, which means we do npm install a LOT. And npm is pretty terrible, with horrible dependency handling so we...

Atom feeds with PHP 5 Dom and XSL

All blogs require silly amounts of feed generators, right? And this is a silly blog so requires a silly generator. The entire site is...